hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Thusoo (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-203) fix eclipse templates to get junit tests working
Date Mon, 05 Jan 2009 14:03:44 GMT

    [ https://issues.apache.org/jira/browse/HIVE-203?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12660763#action_12660763
] 

Ashish Thusoo commented on HIVE-203:
------------------------------------

I was able to import the project using this patch (this is very useful), however I got the
following errors:

1. There is a duplicate entry for serde/src/gen-java in the .classpath files - this gives
a build error in eclipse
2. The build is looking for hadoopcore/hadoop-0.17.2.1 - in the checked in files we should
probably have this as 0.19. (I was able to get rid of the build issues once I did ant package
-Dhadoop.version="0.17.2.1"

I think without fixing 1 this will not build in eclipse.

Also for the hadoop version, we can potentially do the following in the .classpath file so
that it brings in the correct version.

Using 

@HADOOPVER@ in .classpath similar to how we use @PROJECT@ in .project

and then add the following in <root>/build.xml

<filter token="HADOOPVER" value="${hadoop.version}"/>

after the token for PROJECT

I do see the test configurations... This looks great..

However, when I try to run say the TestCliDriver configuration it seems to give me an error


"Input type of the launch configuration does not exist".

Also while running TestHive I get the following:

"The archive: /hive_local_ws3/build/metastore/metastore_model.jar which is referenced by the
classpath, does not exist."

even though the jar is there (I checked it).


> fix eclipse templates to get junit tests working
> ------------------------------------------------
>
>                 Key: HIVE-203
>                 URL: https://issues.apache.org/jira/browse/HIVE-203
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Build Infrastructure
>    Affects Versions: 0.2.0
>            Reporter: Raghotham Murthy
>            Assignee: Raghotham Murthy
>             Fix For: 0.2.0
>
>         Attachments: hive-203.1.patch, hive-203.2.patch
>
>
> right now eclipse templates are not complete.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message