hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashish Thusoo (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-116) Test run fails to complete
Date Fri, 05 Dec 2008 16:50:44 GMT

    [ https://issues.apache.org/jira/browse/HIVE-116?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12653862#action_12653862
] 

Ashish Thusoo commented on HIVE-116:
------------------------------------

Hmm.

for some reason we were able to run the tests fine (apart from a couple of diffs in the test
run). We will continue to investigate this.

Regarding the patch,

I am fine with the junit.jar change.

The dependency between the test and deploy should however be in build-common.xml (dependency
between test and jar) as otherwise this dependency will not be picked up if the test is run
from within one of the sub directories.

> Test run fails to complete
> --------------------------
>
>                 Key: HIVE-116
>                 URL: https://issues.apache.org/jira/browse/HIVE-116
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Testing Infrastructure
>    Affects Versions: 0.19.0
>         Environment: 32bit Ubuntu Hardy, Java6, Ant 1.7
>            Reporter: Johan Oskarsson
>            Assignee: Johan Oskarsson
>            Priority: Critical
>             Fix For: 0.19.0
>
>         Attachments: HIVE-116.patch, test.log
>
>
> When running either "ant deploy test" or just "ant test" from a newly checked out hive
trunk (with HIVE-90 applied) the test suite fails to complete. Not because tests cases fail
but because classes can't be found. I assume it has something to do with the order the different
modules are compiled in before the tests are run.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message