hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Srinivas S Tamvada <tssrini...@yahoo.com>
Subject Problem using third party shared object in map function
Date Fri, 15 May 2015 14:49:08 GMT
HiI am trying to use a third party jar, which comes with a shared object file.
When I try a jar which does not need a shared object, my map job works:example:  hadoop jar
/tmp/yarn-wordcount-0.0.1-SNAPSHOT.jar  mypack.WordCount  -libjars /folder/containing/external/jars/
I have tried many ways to get it to work when I use a jar which needs a shared object file.Some
websites on cloudera and stack overflow have suggestions.
The official solution seems to be deprecated.http://hadoop.apache.org/docs/r2.4.1/hadoop-project-dist/hadoop-common/NativeLibraries.html
I have even tried copying my shared object file into these folders:/opt/cloudera/parcels/CDH-5.4.0-1.cdh5.4.0.p0.27/lib/hadoop-0.20-mapreduce/lib/native

can someone point out the latest and greatest way to use external jar files which need .so
files ?
Thank you.

View raw message