hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kiran Kumar.M.R" <Kiran.Kumar...@huawei.com>
Subject RE: Problem with Hadoop 2.6 native build Windows
Date Wed, 22 Apr 2015 09:33:38 GMT
Hi Yves,
For 64-bit compilation, it should work out of box.

What command are you using to build?
Below build command works for me
$mvn install -Pnative-win -DskipTests

Ensure you have cmake also.


Regards,
Kiran
__________________________________________________________________________________________________________
This e-mail and its attachments contain confidential information from HUAWEI, which is intended
only for the person or entity whose address is listed above. Any use of the information contained
herein in any way (including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive
this e-mail in error, please notify the sender by phone or email immediately and delete it!
__________________________________________________________________________________________________________




From: yves callaert [mailto:yves_callaert@hotmail.com]
Sent: Wednesday, April 22, 2015 13:16
To: user@hadoop.apache.org
Subject: Problem with Hadoop 2.6 native build Windows

Hi All,
I am currently trying to build Hadoop 2.6 for windows from the source code but I encountered
a problem in the "libwinutils.c" class.
The problem is with the following line of code:
const WCHAR* wsceConfigRelativePath = WIDEN_STRING(STRINGIFY(WSCE_CONFIG_DIR)) L"\\" WIDEN_STRING(STRINGIFY(WSCE_CONFIG_FILE));
Visual studio gives me the error "C2056: 'L': Undeclared Identifier"
Following the above error , I get "Error C2099: initializer is not a constant"

Build environment:
Windows 7 Ultimate SP1 64 Bit
Cygwin installed
Microsoft SDK 7.1 installed
Visual studio 2010 installed
Protocol Buffer 2.5 installed

I've been able to build hadoop 2.2 and 2.4 but this one seems to elude me.
I would really appreciate any insight into the problem.

With regards,
Yves

Mime
View raw message