hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Murali <anand_vi...@yahoo.com>
Subject Re: Connection Refused Error
Date Mon, 20 Apr 2015 11:45:35 GMT
Yes. All Hadoop commands. The error message is linked to IP address,a dn I checked Hadoop wiki,
this is a network issue on Ubuntu. Unfortunately, I dont know much about networks.
 Anand Murali  11/7, 'Anand Vihar', Kandasamy St, MylaporeChennai - 600 004, IndiaPh: (044)-
28474593/ 43526162 (voicemail) 

     On Monday, April 20, 2015 5:13 PM, Himawan Mahardianto <mahardianto@ugm.ac.id>

 have you try: hdfs dfs -ls / *with slash in the end of command?
On Mon, Apr 20, 2015 at 5:50 PM, Anand Murali <anand_vihar@yahoo.com> wrote:

Hi All:
I am using Ubuntu 14.10 desktop and Hadoop-2.6 pseudo mode. Start-dfs/Stop-dfs is normal.
However, after a couple of times of usage, when I try to connect to HDFS,, I am refused connection.
Find below
anand_vihar@Latitude-E5540:~$ ssh localhost
Welcome to Ubuntu 14.10 (GNU/Linux 3.16.0-34-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

Last login: Mon Apr 20 15:43:58 2015 from localhost
anand_vihar@Latitude-E5540:~$ cd hadoop-2.6.0
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ . .hadoop
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ start-dfs.sh
Starting namenodes on [localhost]
localhost: starting namenode, logging to /home/anand_vihar/hadoop-2.6.0/logs/hadoop-anand_vihar-namenode-Latitude-E5540.out
localhost: starting datanode, logging to /home/anand_vihar/hadoop-2.6.0/logs/hadoop-anand_vihar-datanode-Latitude-E5540.out
Starting secondary namenodes [] starting secondarynamenode, logging to /home/anand_vihar/hadoop-2.6.0/logs/hadoop-anand_vihar-secondarynamenode-Latitude-E5540.out
anand_vihar@Latitude-E5540:~/hadoop-2.6.0$ hdfs dfs -ls
ls: Call From Latitude-E5540/ to localhost:9000 failed on connection exception: java.net.ConnectException:
Connection refused; For more details see:  http://wiki.apache.org/hadoop/ConnectionRefused

If I completely delete Hadoop and re-install, it starts working. Can somebody advise on this
Many thanks

 Anand Murali  

View raw message