hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krish Donald <gotomyp...@gmail.com>
Subject Cloudera Manager Installation is failing
Date Mon, 02 Mar 2015 22:21:21 GMT

I am trying to install Cloudera manager but it is failing and below is the
log file:
I have uninstalled postgres and tried again but still the same error.

[root@nncloudera cloudera-manager-installer]# more 5.start-embedded-db.log
mktemp: failed to create file via template `/tmp/XXXXXXXX': Permission
/usr/share/cmf/bin/initialize_embedded_db.sh: line 393: $PASSWORD_TMP_FILE:
ambiguous redirect
The files belonging to this database system will be owned by user
This user must also own the server process.
The database cluster will be initialized with locale en_US.UTF8.
The default text search configuration will be set to "english".
fixing permissions on existing directory
/var/lib/cloudera-scm-server-db/data ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 32MB
creating configuration files ... ok
creating template1 database in /var/lib/cloudera-scm-server-db/data/base/1
... ok
initializing pg_authid ... ok
initdb: could not open file "" for reading: No such file or directory
initdb: removing contents of data directory
Could not initialize database server.
  This usually means that your PostgreSQL installation failed or isn't
working properly.
  PostgreSQL is installed using the set of repositories found on this
machine. Please
  ensure that PostgreSQL can be installed. Please also uninstall any other
instances of
  PostgreSQL and then try again., giving up

Please suggest.


View raw message