hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohith Sharma K S <rohithsharm...@huawei.com>
Subject RE: Starting YARN in HA mode Hadoop 2.5.1
Date Tue, 18 Nov 2014 16:19:22 GMT
You need to start manually. Yarn does not support starting all the RM’s in cluster.

Thanks & Regards
Rohith Sharma K S

From: Jogeshwar Karthik Akundi [mailto:ajkarthik@gmail.com]
Sent: 18 November 2014 19:15
To: user@hadoop.apache.org
Subject: Starting YARN in HA mode Hadoop 2.5.1

I am using Hadoop 2.5.1 and trying to enable HA mode for NN and RM.

the start-dfs.sh script provided starts both the namenodes and all the datanodes.
However, the start-yarn.sh starts only one RM and all the NodeManagers.

till now, these scripts allowed me to startup the entire cluster from a single machine (the
primary node). But now, the secondary RM is not starting up.

I tried to google around but couldn't find any information. Tried reading through the yarn-daemon*.sh
scripts, but don't find a hint on how to start both the RMs at one shot.

Any pointers? Am I missing something?

There is no charge for awesomeness
View raw message