hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian C. Huffman" <bhuff...@etinternational.com>
Subject Re: YARN Logs
Date Tue, 15 Jul 2014 17:03:51 GMT
Looking at the docs, the yarn.nodemanager.remote-app-log-dir variable 
description says "Where to aggregate logs to."  But I don't want to use 
log aggregation.

Does the 'yarn logs' command look anywhere else if 
yarn.log-aggregation-enable is set to false?

-b

On 07/15/2014 12:10 PM, Adam Kawa wrote:
> For example, the remote location is configured 
> via yarn.nodemanager.remote-app-log-dir and defaults to "/tmp/logs".
> This is why, you see:
> /Logs not available at 
> */tmp/logs*/hadoop/logs/application_1405396841766_0003./
>
> PS.
> The full path is configured via 
> ${yarn.nodemanager.remote-app-log-dir}/${username}/${yarn.nodemanager.remote-app-log-dir-suffix}/${application-id}
>
>
>
> 2014-07-15 18:08 GMT+02:00 Adam Kawa <kawa.adam@gmail.com 
> <mailto:kawa.adam@gmail.com>>:
>
>     IMHO,
>     $ yarn logs looks for aggregated logs at remote location.
>
>
>
>     2014-07-15 16:49 GMT+02:00 Brian C. Huffman
>     <bhuffman@etinternational.com <mailto:bhuffman@etinternational.com>>:
>
>         All,
>
>         I am running a small cluster with hadoop-2.2.0 installed on an
>         NFS shared directory.  Since all nodes can access, I do not
>         want to enable log aggregation.
>
>         My understanding was that if aggregation wasn't enabled, the
>         'yarn logs' command would just look in the
>         $HADOOP_HOME/logs/userlogs dir, but that isn't happening:
>         [hadoop@host1 ~]$ yarn logs -applicationId
>         application_1405396841766_0003
>         14/07/15 10:35:58 INFO client.RMProxy: Connecting to
>         ResourceManager at host1/172.17.1.1:8032 <http://172.17.1.1:8032>
>         Logs not available at
>         /tmp/logs/hadoop/logs/application_1405396841766_0003
>         Log aggregation has not completed or is not enabled.
>
>         Can anyone suggest what I might be doing wrong?
>
>         Thanks,
>         Brian
>
>
>


Mime
View raw message