hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod Kumar Vavilapalli <vino...@hortonworks.com>
Subject Re: pipes on hadoop 2.2.0 crashes
Date Fri, 13 Dec 2013 18:22:50 GMT

Could it just be LocalJobRunner? Can you try it on a cluster? We've tested pipes on clusters,
so will be surprised if it doesn't work there.


On Dec 13, 2013, at 7:44 AM, Mauro Del Rio <mdrio1980@gmail.com> wrote:

> Hi, I tried to run a simple test with pipes, but it crashes.
> java.lang.Exception: java.lang.NullPointerException
> 	at org.apache.hadoop.mapred.LocalJobRunner$Job.run(LocalJobRunner.java:403)
> Caused by: java.lang.NullPointerException
> 	at org.apache.hadoop.mapred.pipes.Application.<init>(Application.java:104)
> 	at org.apache.hadoop.mapred.pipes.PipesMapRunner.run(PipesMapRunner.java:69)
> 	at org.apache.hadoop.mapred.MapTask.runOldMapper(MapTask.java:429)
> 	at org.apache.hadoop.mapred.MapTask.run(MapTask.java:341)
> 	at org.apache.hadoop.mapred.LocalJobRunner$Job$MapTaskRunnable.run(LocalJobRunner.java:235)
> 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
> 	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
> 	at java.lang.Thread.run(Thread.java:662)
> 13/12/13 16:38:03 INFO mapreduce.Job: Job job_local1570213319_0001 running in uber mode
: false
> 13/12/13 16:38:03 INFO mapreduce.Job:  map 0% reduce 0%
> 13/12/13 16:38:03 INFO mapreduce.Job: Job job_local1570213319_0001 failed with state
FAILED due to: NA
> 13/12/13 16:38:03 INFO mapreduce.Job: Counters: 0
> Exception in thread "main" java.io.IOException: Job failed!
> 	at org.apache.hadoop.mapred.JobClient.runJob(JobClient.java:836)
> 	at org.apache.hadoop.mapred.pipes.Submitter.runJob(Submitter.java:264)
> 	at org.apache.hadoop.mapred.pipes.Submitter.run(Submitter.java:503)
> 	at org.apache.hadoop.mapred.pipes.Submitter.main(Submitter.java:518)
> The line Application.java:104 is: byte[]  password = jobToken.getPassword();
> so jobToken seems to be null.
> It does not depend upon c++ code, since the error occurs before it is launched.
> I run it on Ubuntu 12.04 32 bit using the binary tarball.
> Any idea why it doesn't work?
> -- 
> Mauro

NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

View raw message