hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Machtolff <amachto...@askcts.com>
Subject RE: Heterogeneous Cluster
Date Mon, 25 Nov 2013 22:56:54 GMT
Yes, I set one up as a test. I had a windows cluster of 3 machines, and added a 4th Linux node.
The Data Node was able to connect and replicate, but MR jobs failed. JobTracker/TaskTracker
wasn't translating the path to the data block. They were telling the Linux node to look in
C:\.... for the data block, and that obviously didn't work.

I feel like it's only a small change away from working, at that point, I had to shift my focus
and couldn't work on it any more.

Have you had any success?

Andrew

________________________________
Andrew Machtolff / Senior Consultant

[http://images.askcts.com/images/cts_logo_email.png]<http://www.askcts.com/>
www.askcts.com<http://www.askcts.com/>
amachtolff@askcts.com<mailto:amachtolff@askcts.com>
[http://images.askcts.com/images/cts_logo_linkedin.png]<http://www.linkedin.com/company/cts-inc>[http://images.askcts.com/images/cts_logo_twitter.png]<https://twitter.com/askCTS>[http://images.askcts.com/images/cts_logo_facebook.png]<https://www.facebook.com/askCTS>

From: Ian Jackson [mailto:Ian_Jackson@trilliumsoftware.com]
Sent: Friday, November 22, 2013 4:05 PM
To: user@hadoop.apache.org
Subject: Heterogeneous Cluster

Has anyone set up a Heterogeneous cluster, some Windows nodes and Linux nodes?

Mime
View raw message