hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Help: error in hadoop build
Date Wed, 29 May 2013 18:36:51 GMT
What's the output of:

protoc --version

You should be using 2.4.1

Cheers

On Wed, May 29, 2013 at 11:33 AM, John Lilley <john.lilley@redpoint.net>wrote:

>  Sorry if this is a dumb question, but I’m not sure where to start.  I am
> following BUILDING.txt instructions for source checked out today using git:
> ****
>
> git clone git://git.apache.org/hadoop-common.git Hadoop****
>
> ** **
>
> Following build steps and adding -X for more logging:****
>
> mvn compile -X****
>
> ** **
>
> But I get this error in Hadoop common****
>
> [WARNING] [protoc,
> --java_out=/home/jlilley/hadoop/hadoop-common-project/hadoop-common/target/generated-sources/java,
> -I/home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/Security.proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/ZKFCProtocol.proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/RpcHeader.proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/ProtobufRpcEngine.proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/IpcConnectionContext.proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/HAServiceProtocol.proto,
> /home/jlilley/hadoop/hadoop-common-project/hadoop-common/src/main/proto/ProtocolInfo.proto]
> failed with error code 1****
>
> [DEBUG] Security.proto:22:8: Option "java_generate_equals_and_hash"
> unknown.****
>
> [ERROR] protoc compiler error****
>
> ** **
>
> The following were installed today, this is basically on a clean CentOS6
> system:****
>
> # history | grep yum****
>
>    81  yum install protobuf-compiler****
>
>    82  yum install gcc****
>
>    84  yum install gcc-c++****
>
>    85  yum install cmake****
>
>    86  yum install make****
>
>    87  yum install zlib****
>
>    90  yum install git****
>
>    93  yum install eclipse****
>
> ** **
>
> This seems to indicate that the problem may have to do with a too-recent
> protobuf and additional settings that must be applied because of that:****
>
>
> http://mail-archives.apache.org/mod_mbox/hadoop-mapreduce-dev/201106.mbox/%3C4DFA3C67.50108@gmail.com%3E
> ****
>
> ** **
>
> Thanks****
>
> John****
>

Mime
View raw message