hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: Hadoop + Fuse: Compilation errors
Date Fri, 08 Feb 2013 14:52:48 GMT
Replying to myself ;)

I found the issue, I'm posting here in case it can help someone else.

To solve that you need to install libtool.

http://mail-archives.apache.org/mod_mbox/hadoop-hdfs-dev/201106.mbox/%3CBANLkTik0WgkdWkdUGnOrQa7DH1UA8pOWvg@mail.gmail.com%3E

It's still failing later on a compilation issue, but at least I made
some progress...

JM

2013/2/8, Jean-Marc Spaggiari <jean-marc@spaggiari.org>:
> Hi,
>
> I'm trying to install FUSE with Hadoop 1.0.3 and I'm facing some issues.
>
> I'm following the steps I have there:
> http://wiki.apache.org/hadoop/MountableHDFS
>
> I have extracted 1.0.3 code using svn checkout
> http://svn.apache.org/repos/asf/hadoop/common/tags/release-X.Y.Z/
> hadoop-common-X.Y.Z
>
> ant compile-c++-libhdfs -Dlibhdfs=1 is working fine, but  ant package
> is failing on create-native-configure
> create-native-configure:
>      [exec] configure.ac:47: error: possibly undefined macro:
> AC_PROG_LIBTOOL
>      [exec]       If this token and others are legitimate, please use
> m4_pattern_allow.
>      [exec]       See the Autoconf documentation.
>      [exec] autoreconf: /usr/bin/autoconf failed with exit status: 1
>
> BUILD FAILED
> /home/hadoop/hadoop-1.0.3-src/hadoop-common-1.0.3/build.xml:618: exec
> returned: 1
>
> I'm on amd64. And on the wiki page,it's saying that I have to update
> the Makefile in a specific directory, but there is no Makefile in this
> directory... So I'm a bit blocked there. Any help will be welcome.
>
> Thanks,
>
> jM
>

Mime
View raw message