hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amith D K <amit...@huawei.com>
Subject RE: Several Inconsistencies between fsck and NN UI reports
Date Tue, 24 Apr 2012 02:03:09 GMT
Hi

Yes we are using append
Thanks shawn for the link  http://stackoverflow.com/questions/7997587/under-replicated-blocks-count-is-inaccurate-buy-why

But currently we are using Branch-2 (Is Branch-2 append is also unstable).

I didnt check FSCK  "-openforwrite" if the cluster is still up I will check and update u guys

and

2. The NN UI is reporting missing blocks and on clicking the link there are no missing blocks
displayed, but FSCK displays no missing blocks.

For this point I got a clue where missing blocks are displayed based on number of entries
in QUEUE_WITH_CORRUPT_BLOCKS, and link didn't display any blocks since the entry in QUEUE_WITH_CORRUPT_BLOCKS
is not having a entry in CorruptReplicasMap.

Is there any possibility of having this scenario?

Thanks and Regards
Amith
________________________________
From: Todd Lipcon [todd@cloudera.com]
Sent: Tuesday, April 24, 2012 2:50 AM
To: hdfs-user@hadoop.apache.org
Subject: Re: Several Inconsistencies between fsck and NN UI reports

Hi Amith,

Did you try fsck with the "-openforwrite" flag?

-Todd

On Mon, Apr 23, 2012 at 11:19 AM, Amith D K <amithdk@huawei.com<mailto:amithdk@huawei.com>>
wrote:
Hi All,

In one of our test cluster we have seen several Inconsistencies in between NN UI and FSCK
report.

1. The number of under replicated blocks  in UI and FSCK are not matching

2. The NN UI is reporting missing blocks and on clicking the link there are no missing blocks
displayed, but FSCK displays no missing blocks.

All the cluster are running on Branch-2.
This is a simple NN setup with 3 DN.

Did any one face the same problem till now?

Thanks and Regards
Amith



--
Todd Lipcon
Software Engineer, Cloudera

Mime
View raw message