hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alo alt <wget.n...@googlemail.com>
Subject Re: HDFS mounting issue using Hadoop-Fuse on Fully Distributed Cluster?
Date Thu, 26 Apr 2012 10:56:06 GMT
Hi,

I wrote a small writeup about:
http://mapredit.blogspot.de/2011/11/nfs-exported-hdfs-cdh3.html

As you see, the FS is mounted as nobody and you try as root. Change the permissions in your
hdfs:
hadoop -dfs chmod / chown ....

- Alex

--
Alexander Lorenz
http://mapredit.blogspot.com

On Apr 26, 2012, at 12:50 PM, Manu S wrote:

> Dear All,
> 
> I have installed *Hadoop-fuse* to mount the HDFS filesystem locally . I
> could mount the HDFS without any issues.But I am not able to do any file
> operations like *delete, copy, move* etc directly. The directory ownership
> automatically changed to *nobody:nobody* while mounting.
> 
> *[root@namenode ~]# ls -ld /hdfs_mount/
> drwxr-xr-x 2 root root 4096 Apr 3 16:22 /hdfs_mount/
> 
> [root@namenode ~]# hadoop-fuse-dfs dfs://namenode:8020 /hdfs_mount/** **
> INFO fuse_options.c:162 Adding FUSE arg /hdfs_mount/
> 
> [root@namenode ~]# ls -ld /hdfs_mount/* *
> drwxrwxr-x 10 nobody nobody 4096 Apr 5 13:22 /hdfs_mount/*
> 
> I tried the same with *pseudo-distributed node*,but its working fine. I can
> do any normal file operations after mounting the HDFS.
> 
> Appreciate your help on the same.
> 
> -- 
> Thanks & Regards
> ----
> *Manu S*
> SI Engineer - OpenSource & HPC
> Wipro Infotech
> Mob: +91 8861302855                Skype: manuspkd
> www.opensourcetalk.co.in


Mime
View raw message