hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kiranprasad" <kiranprasa...@imimobile.com>
Subject Re: While starting HDFS process getting stucked.
Date Fri, 16 Sep 2011 08:54:49 GMT
Yes I ve formatted the namenode.

From: Sudharsan Sampath 
Sent: Friday, September 16, 2011 2:11 PM
To: hdfs-user@hadoop.apache.org 
Subject: Re: While starting HDFS process getting stucked.

Have u formatted ur namenode ? 

Thanks
Sudhan S


On Fri, Sep 16, 2011 at 11:01 AM, kiranprasad <kiranprasad.g@imimobile.com> wrote:

  Hi

  I  am new to Hadoop and PIG,

  For Cluster I have 3 VMs(10.0.0.61-master, 10.0.0.62,10.0.0.63 - Slaves)

  I ve installed PIG in 10.0.0.61 VM.=20

  Hadoop version : hadoop-0.20.2 and  PIG  : pig-0.8.1
  I ve updated the xmls , please find the below

  mapred site.xml
  --------------
  <configuration>
    <property>
          <name>mapred.job.tracker</**name>
    <value>10.0.0.61:8021</value>
    </property>
  </configuration>


  core-site.xml
  ----------
  <configuration>
    <property>
     <name>fs.default.name</name>
     <value>hdfs://10.0.0.61:8020</**value>

    </property>
  </configuration>

  Hdfs-site.xml
  ----------------
  <configuration>
  <property>
    <name>fs.default.name</name>
    <value>hdfs://10.0.0.61:8020</**value>
  </property>
  <property>
    <name>mapred.job.tracker</**name>
    <value>10.0.0.61:8021</value>

  </property>
  <property>
     <name>dfs.replication</name>
     <value>2</value>
  </property>

  masters
  ---------
  10.0.0.61

  slaves
  --------

  10.0.0.62
  10.0.0.63


  I ve tried with hadoop fs -ls but still facing the same problem.

  [kiranprasad.g@pig4 hadoop-0.20.2]$ bin/start-all.sh
  starting namenode, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-nameno=
  de-pig4.out
  10.0.0.62: starting datanode, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-datano=
  de-pig3.out
  10.0.0.63: starting datanode, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-datano=
  de-pig2.out
  10.0.0.61: starting secondarynamenode, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-second=
  arynamenode-pig4.out
  starting jobtracker, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-jobtra=
  cker-pig4.out
  10.0.0.63: starting tasktracker, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-tasktr=
  acker-pig2.out
  10.0.0.62: starting tasktracker, logging to
  /home/kiranprasad.g/hadoop-0.20.2/bin/../logs/hadoop-kiranprasad.g-tasktr=
  acker-pig3.out
  [kiranprasad.g@pig4 hadoop-0.20.2]$
  [kiranprasad.g@pig4 hadoop-0.20.2]$
  [kiranprasad.g@pig4 hadoop-0.20.2]$ bin/hadoop fs -ls

  After this it stopped running, it got stucked.


  Regards
  Kiran.G

Mime
View raw message