hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcos Ortiz <mlor...@uci.cu>
Subject Re: Starting Datanode
Date Sat, 21 May 2011 17:13:11 GMT
On 05/21/2011 11:38 AM, Harsh J wrote:
> FWIW, my 'java' output tells me:
>
> -jvm is a synonym for the "client" VM  [deprecated]
>
> i.e., -jvm == -client
>
> I do not know when it was introduced, but it says deprecated in u24.
>
> Additionally, I do not think "java -jvm server" makes any sense at
> all. Looks like a genuine typo/overlook/bug. Do file a JIRA for this,
> and fix it to use "-client" alone, if I understand what it really
> means to do if EUID == 0.
>
> On Sat, May 21, 2011 at 4:27 AM, Anh Nguyen<anguyen@redhat.com>  wrote:
>> On 05/20/2011 02:33 PM, Marcos Ortiz wrote:
>>> On 05/20/2011 04:08 PM, Anh Nguyen wrote:
>>>> On 05/20/2011 02:06 PM, Marcos Ortiz wrote:
>>>>> On 05/20/2011 04:27 PM, Marcos Ortiz wrote:
>>>>>> On 05/20/2011 03:46 PM, Anh Nguyen wrote:
>>>>>>> On 05/20/2011 01:15 PM, Marcos Ortiz wrote:
>>>>>>>> On 05/20/2011 01:02 PM, Anh Nguyen wrote:
>>>>>>>>> Hi,
>>>>>>>>>
>>>>>>>>> I just upgraded to hadoop-0.20.203.0, and am having problem
starting
>>>>>>>>> the
>>>>>>>>> datanode:
>>>>>>>>> # hadoop datanode
>>>>>>>>> Unrecognized option: -jvm
>>>>>>>>> Could not create the Java virtual machine.
>>>>>>>>>
>>>>>>>>> It looks like it has something to do with daemon.sh,
particularly
>>>>>>>>> the
>>>>>>>>> setting of HADOOP_OPTS:
>>>>>>>>>    if [[ $EUID -eq 0 ]]; then
>>>>>>>>>      HADOOP_OPTS="$HADOOP_OPTS -jvm server $HADOOP_DATANODE_OPTS"
>>>>>>>>>    else
>>>>>>>>>      HADOOP_OPTS="$HADOOP_OPTS -server $HADOOP_DATANODE_OPTS"
>>>>>>>>>    fi
>>>>>>>>>
>>>>>>>>> Am I missing something?
>>>>>>>>>
>>>>>>>>> Thanks in advance.
>>>>>>>>>
>>>>>>>>> Anh-
>>>>>>>>>
>>>>>>>> Which Java's version are you using?
>>>>>>>>
>>>>>>>>
>>>>>>> # java -version
>>>>>>> java version "1.6.0_20"
>>>>>>> Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
>>>>>>> Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)
>>>>>>>
>>>>>>> It worked with hadoop-0.20.2.
>>>>>>> Anh-
>>>>>> How do you are starting the services? using bin/start-all.sh o simply
>>>>>> the datanode?
>>>>>>
>>>>>>
>>>>> Anh, test first that this option (-jvm is included in that Java
>>>>> version).
>>>>>
>>>>>
>>>> Tested earlier:
>>>> # java -jvm
>>>> Unrecognized option: -jvm
>>>> Could not create the Java virtual machine.
>>>>
>>> Did you check the requirements for that release? I don´t know if this
>>> version require at least a mayor version to 1.6.20.
>>> Did you test with the 1.6.24?
>> Frankly, I have seen/used -jvm. What is it?
>> Anh-
>>> I think that can be a bug.
>>> Take a time to review the last issues for Hadoop on the JIRA of the
>>> project.
>>>
>>> Regards
>>>
>>
>
>
Good points, Harsh
Thanks for clarifire it


-- 
Marcos Luís Ortíz Valmaseda
  Software Engineer (Large-Scaled Distributed Systems)
  University of Information Sciences,
  La Habana, Cuba
  Linux User # 418229
  http://about.me/marcosortiz


Mime
View raw message