hadoop-hdfs-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Disher <jdis...@parad.net>
Subject distcp problems going from hadoop-0.20.1 to -0.20.2
Date Sat, 23 Apr 2011 05:37:03 GMT
I have an existing cluster running hadoop-0.20.1, and I am migrating most of the data to a
new cluster running -0.20.2.  I am seeing this in the namenode logs when I try to run a distcp:

@400000004db263bf29c77134 WARN ipc.Server: Incorrect header or version mismatch from newNN:46111
got version 4 expected version 3
2011-04-23 05:30:55,999 WARN org.apache.hadoop.ipc.Server: Incorrect header or version mismatch
from oldNN:48750 got version 3 expected version 4

When I run my distcp, on either side, it dies with a java.io.IOException/java.io.EOFException.

Ideas?  Am I screwed?  I really don't want to drop my new cluster down to 0.20.1.

-j
Mime
View raw message