hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Íñigo Goiri (Jira) <j...@apache.org>
Subject [jira] [Commented] (HDFS-14739) RBF: LS command for mount point shows wrong owner and permission information.
Date Thu, 22 Aug 2019 19:22:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-14739?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16913627#comment-16913627
] 

Íñigo Goiri commented on HDFS-14739:
------------------------------------

I tried to go through the discussion but it was a little hard to follow so I went for the
patch itself.
I may have missed some of the discussion so excuse me if I say anything redundant here.
Going through the patch:
* It looks like the main issue here is {{defaultNSEnable}}. Have you thought on just enabling
the default namespace? Or even adding a / mount?
* For the new exception, the javadoc should give an example, kind of hard to get otherwise.
* We may want to add the path as a field to the exception.
* When we capture the exception in getListing(), we should do something with it. Maybe log
it. Ideally we should "check" those in the test.
* What is the fix in RouterClientProtocol#811?

> RBF: LS command for mount point shows wrong owner and permission information.
> -----------------------------------------------------------------------------
>
>                 Key: HDFS-14739
>                 URL: https://issues.apache.org/jira/browse/HDFS-14739
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: xuzq
>            Assignee: xuzq
>            Priority: Major
>         Attachments: HDFS-14739-trunk-001.patch, image-2019-08-16-17-15-50-614.png, image-2019-08-16-17-16-00-863.png,
image-2019-08-16-17-16-34-325.png
>
>
> ||source||target namespace||destination||owner||group||permission||
> |/mnt|ns0|/mnt|mnt|mnt_group|755|
> |/mnt/test1|ns1|/mnt/test1|mnt_test1|mnt_test1_group|755|
> |/test1|ns1|/test1|test1|test1_group|755|
> When do getListing("/mnt"), the owner of  */mnt/test1* should be *mnt_test1* instead
of *test1* in result.
>  
> And if the mount table as blew, we should support getListing("/mnt") instead of throw
IOException when dfs.federation.router.default.nameservice.enable is false.
> ||source||target namespace||destination||owner||group||permission||
> |/mnt/test1|ns0|/mnt/test1|test1|test1|755|
> |/mnt/test2|ns1|/mnt/test2|test2|test2|755|
>  
>  



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message