hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-14217) namenode and datanode are not starting
Date Mon, 21 Jan 2019 03:36:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-14217?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16747638#comment-16747638
] 

Akira Ajisaka commented on HDFS-14217:
--------------------------------------

user@hadoop.apache.org is for end-user questions and discussions. https://hadoop.apache.org/mailing_lists.html
Hi [~saichanda], would you e-mail to the list instead of filing an issue in JIRA?

> namenode and datanode are not starting
> --------------------------------------
>
>                 Key: HDFS-14217
>                 URL: https://issues.apache.org/jira/browse/HDFS-14217
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: datanode, namenode
>    Affects Versions: 2.9.2
>            Reporter: saichanda
>            Priority: Trivial
>         Attachments: hadoop-saichanda-namenode-saichanda-OptiPlex-9020.log
>
>
> I am new to hadoop ecosystem. I am setting up a cluster with 4 nodes, one master and
3 slave nodes. I have done the ground work of updating all xml files in hadoop/etc/hadoop
folder. I saved the slaves file. I formatted the namenode. I then started the cluster with
command, sbin/start-dfs.sh. I get to see the lines:
> 'starting namenode on localhost.... starting datanode on slave1...starting datanode on
slave2...starting datanode on slave3... starting secondary namenode..... But when I run jps
command in the terminal of masternode, I see only Jps and Secondary Namenode. When I run jps
command on the slave nodes, I see only Jps, no datanode running on the slaves. What should
I write in my hdfs-site.xml? Currently I set the path for namenode and datanode like... <value>file:/home/user/hadoop_store/hdfs/namenode<\value>
and similarly for datanode as well. In the log file for namenode, I see the line saying "Inconsistent
state: storage directory doesn't exist or not accessible for the path /home/user/hadoop_store/hdfs/namenode.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message