hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bharat Viswanadham (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDDS-941) Rename ChunkGroupInputStream to keyInputStream and ChunkInputStream to BlockInputStream
Date Wed, 09 Jan 2019 01:04:00 GMT

    [ https://issues.apache.org/jira/browse/HDDS-941?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16737706#comment-16737706
] 

Bharat Viswanadham edited comment on HDDS-941 at 1/9/19 1:03 AM:
-----------------------------------------------------------------

Hi [~shashikant]

Thanks for the fix.

*Few minor comments:*
 # 
S3WrapperInputStream.java

        Line 34: _Constructs S3WrapperInputStream with BlockInputStream._ _Should_ _be
changed as_ Constructs S3WrapperInputStream with KeyInputStream. # 
_RpcClient.java: can we expand_ org.apache.hadoop.ozone.client.*;, instead of using *.
 # 
OzoneInputStrea.java:Should it be Constructs OzoneInputStream with KeyInputStream, instead
of Constructs OzoneInputStream with BlockInputStream?
 # 
_OzoneInputStream.java:Existing one_ It uses SCM's {@link _BlockInputStream}, do we need SCM__’__s
here?_ 

 


was (Author: bharatviswa):
Hi [~shashikant]

Thanks for the fix.

*Few minor comments:*
 # 
S3WrapperInputStream.java

        Line 34: _Constructs S3WrapperInputStream with BlockInputStream._ _Should_ _be
changed as_ Constructs S3WrapperInputStream with KeyInputStream. # 
_RpcClient.java: can we expand_ org.apache.hadoop.ozone.client.*;, instead of using *.
 # 
OzoneInputStrea.java:Should it be Constructs OzoneInputStream with KeyInputStream, instead
ofConstructs OzoneInputStream with BlockInputStream?
 # 
{color:#808080}_OzoneInputStream.java:Existing one_{color} It uses SCM's {@link {color:#808080}_BlockInputStream},
do we need SCM__’__s here?_ {color}

> Rename ChunkGroupInputStream to keyInputStream and ChunkInputStream to BlockInputStream
> ---------------------------------------------------------------------------------------
>
>                 Key: HDDS-941
>                 URL: https://issues.apache.org/jira/browse/HDDS-941
>             Project: Hadoop Distributed Data Store
>          Issue Type: Improvement
>          Components: Ozone Client
>    Affects Versions: 0.4.0
>            Reporter: Shashikant Banerjee
>            Assignee: Shashikant Banerjee
>            Priority: Major
>         Attachments: HDDS-941.000.patch
>
>
> ChunkGroupInputStream reads all blocks for a key and ChunkInputStream reads all chunks
of a block. It would be convenient to call ChunkGroupInputStream to KeyInputStream and ChunkInputStream
to BlockInputStream.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message