hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siyao Meng (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-11273) Move TransferFsImage#doGetUrl function to a Util class
Date Wed, 09 Jan 2019 03:53:00 GMT

     [ https://issues.apache.org/jira/browse/HDFS-11273?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Siyao Meng updated HDFS-11273:
    Status: Open  (was: Patch Available)

> Move TransferFsImage#doGetUrl function to a Util class
> ------------------------------------------------------
>                 Key: HDFS-11273
>                 URL: https://issues.apache.org/jira/browse/HDFS-11273
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: hdfs
>            Reporter: Hanisha Koneru
>            Assignee: Hanisha Koneru
>            Priority: Major
>             Fix For: 3.0.0-alpha2
>         Attachments: HDFS-11273-branch-2.001.patch, HDFS-11273-branch-2.002.patch, HDFS-11273-branch-2.002.patch,
HDFS-11273.000.patch, HDFS-11273.001.patch, HDFS-11273.002.patch, HDFS-11273.003.patch, HDFS-11273.004.patch
> TransferFsImage#doGetUrl downloads files from the specified url and stores them in the
specified storage location. HDFS-4025 plans to synchronize the log segments in JournalNodes.
If a log segment is missing from a JN, the JN downloads it from another JN which has the required
log segment. We need TransferFsImage#doGetUrl and TransferFsImage#receiveFile to accomplish
> So we propose to move the said functions to a Utility class so as to be able to use it
for JournalNode syncing as well, without duplication of code.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message