hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ayush Saxena (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (HDFS-14056) Fix error messages in HDFS-12716
Date Fri, 09 Nov 2018 06:23:00 GMT

     [ https://issues.apache.org/jira/browse/HDFS-14056?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ayush Saxena reassigned HDFS-14056:
-----------------------------------

    Assignee: Ayush Saxena

> Fix error messages in HDFS-12716
> --------------------------------
>
>                 Key: HDFS-14056
>                 URL: https://issues.apache.org/jira/browse/HDFS-14056
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: hdfs
>    Affects Versions: 2.10.0, 3.2.0, 3.0.4, 3.1.2
>            Reporter: Adam Antal
>            Assignee: Ayush Saxena
>            Priority: Minor
>
> There are misleading error messages in the committed HDFS-12716 patch.
> As I saw in the code in DataNode.java:startDataNode
> {code:java}
>     throw new DiskErrorException("Invalid value configured for "
>         + "dfs.datanode.failed.volumes.tolerated - " + volFailuresTolerated
>         + ". Value configured is either greater than -1 or >= "
>         + "to the number of configured volumes (" + volsConfigured + ").");
>   }
> {code}
> Here the error message seems a bit misleading. The error comes up when the given quantity
in the configuration set to volsConfigured is set lower than -1 but in that case the error
should say something like "Value configured is either _less_ than -1 or >= ...".
> Also the general error message in DataNode.java
> {code:java}
> public static final String MAX_VOLUME_FAILURES_TOLERATED_MSG = "should be greater than
-1";
> {code}
> May be better changed to "should be greater than _or equal to_ -1" to be precise, as
-1 is a valid choice.
> In hdfs-default.xml I couldn't understand the phrase "The range of the value is -1 now,
-1 represents the minimum of volume valids is 1." It might be better to write something clearer
like "The minimum is -1 representing 1 valid remaining volume".



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message