hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dinesh Chitlangia (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDDS-808) Simplify OMAction and DNAction classes used for AuditLogging
Date Mon, 19 Nov 2018 20:00:00 GMT

    [ https://issues.apache.org/jira/browse/HDDS-808?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16692182#comment-16692182

Dinesh Chitlangia commented on HDDS-808:

Currently, interface AuditAction is implemented by OMAction, DNAction which define the respective
public interface AuditAction {
   * Implementation must override.
   * @return String
  String getAction();
As proposed in this jira, if we are to remove {{getAction()}}, then the interface itself becomes
pointless and we might as well remove this interface altogether.

I am fine with removing this interface.
[~ajayydv] , [~anu] - thoughts?

> Simplify OMAction and DNAction classes used for AuditLogging
> ------------------------------------------------------------
>                 Key: HDDS-808
>                 URL: https://issues.apache.org/jira/browse/HDDS-808
>             Project: Hadoop Distributed Data Store
>          Issue Type: Improvement
>          Components: Ozone Datanode, Ozone Manager
>            Reporter: Dinesh Chitlangia
>            Assignee: Dinesh Chitlangia
>            Priority: Minor
>              Labels: logging
> While reviewing HDDS-120, [~ajayydv] suggested to simplify these class by removing the
constructor and the getAction().
> Refer review comment: https://issues.apache.org/jira/browse/HDDS-120?focusedCommentId=16670495&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-16670495

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message