hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiaoyu Yao (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDDS-704) Fix the Dependency convergence issue on HDDS-4
Date Sat, 20 Oct 2018 04:08:00 GMT

    [ https://issues.apache.org/jira/browse/HDDS-704?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16657500#comment-16657500
] 

Xiaoyu Yao edited comment on HDDS-704 at 10/20/18 4:07 AM:
-----------------------------------------------------------

bcpkix-jdk15on depends on bcprov-jdk15on.

One way to fix this is to exclude bcprov-jdk15on when bringing in bcpkix-jdk15o dependency.


The other way is to simply drop the explicit dependency on bcprov-jdk15on and depend only
on bcpkix-jdk15on. 

Since we don't have specific version requirement on bcprov-jdk15on, I incline the second approach
and I will post a patch shortly. 
 


was (Author: xyao):
bcpkix-jdk15on depends on bcprov-jdk15on.

Once way to fix this is to exclude bcprov-jdk15on when bringing in bcpkix-jdk15o dependency.


The other way is to simply drop the explicit dependency on bcprov-jdk15on and depend only
on bcpkix-jdk15on. 

Since we don't have specific version requirement on bcprov-jdk15on, I incline the second approach
and I will post a patch shortly. 
 

> Fix the Dependency convergence issue on HDDS-4
> ----------------------------------------------
>
>                 Key: HDDS-704
>                 URL: https://issues.apache.org/jira/browse/HDDS-704
>             Project: Hadoop Distributed Data Store
>          Issue Type: Sub-task
>            Reporter: Xiaoyu Yao
>            Assignee: Xiaoyu Yao
>            Priority: Major
>         Attachments: HDDS-704-HDDS-4.001.patch
>
>
> {code}
> Dependency convergence error for org.bouncycastle:bcprov-jdk15on:1.54 paths to dependency
are:
> +-org.apache.hadoop:hadoop-hdds-common:0.4.0-SNAPSHOT
>   +-org.bouncycastle:bcprov-jdk15on:1.54
> and
> +-org.apache.hadoop:hadoop-hdds-common:0.4.0-SNAPSHOT
>   +-org.bouncycastle:bcpkix-jdk15on:1.54
>     +-org.bouncycastle:bcprov-jdk15on:1.60
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence failed with
message:
> Failed while enforcing releasability. See above detailed error message.
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message