hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siyao Meng (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-13879) FileSystem: Should allowSnapshot() and disallowSnapshot() be part of it?
Date Tue, 28 Aug 2018 20:59:00 GMT

     [ https://issues.apache.org/jira/browse/HDFS-13879?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Siyao Meng updated HDFS-13879:
------------------------------
    Summary: FileSystem: Should allowSnapshot() and disallowSnapshot() be part of it?  (was:
FileSystem: Should allowSnapshot() and disallowSnapshot() be part it?)

> FileSystem: Should allowSnapshot() and disallowSnapshot() be part of it?
> ------------------------------------------------------------------------
>
>                 Key: HDFS-13879
>                 URL: https://issues.apache.org/jira/browse/HDFS-13879
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Siyao Meng
>            Priority: Major
>
> I wonder whether we should add allowSnapshot() and disallowSnapshot() to FileSystem abstract
class.
> My rationale is that createSnapshot(), renameSnapshot() and deleteSnapshot() are already
part of it.
> Any reason why we don't want to do this?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message