hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lokesh Jain (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDDS-265) Move numPendingDeletionBlocks and deleteTransactionId from ContainerData to KeyValueContainerData
Date Mon, 13 Aug 2018 14:15:00 GMT

    [ https://issues.apache.org/jira/browse/HDDS-265?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16578324#comment-16578324
] 

Lokesh Jain commented on HDDS-265:
----------------------------------

[~GeLiXin] Thanks for updating the patch! Please find my comments below.
 # We can use default keyword to provide a default implementation.
{code:java}
default boolean isValidContainerType(ContainerProtos.ContainerType type) {
  return false;
}{code}
We can then remove the implementation provided in the subclasses.
 # RandomContainerDeletionChoosingPolicy:59,60 - The change should be reverted. We can use
KeyValueContainerData cast to print the pending blocks number.
 # There is a compilation failure after applying the patch. The failure occurs for ContainerSet
class. I think we can have a getContainerReport api in Container.java?

> Move numPendingDeletionBlocks and deleteTransactionId from ContainerData to KeyValueContainerData
> -------------------------------------------------------------------------------------------------
>
>                 Key: HDDS-265
>                 URL: https://issues.apache.org/jira/browse/HDDS-265
>             Project: Hadoop Distributed Data Store
>          Issue Type: Bug
>    Affects Versions: 0.2.1
>            Reporter: Hanisha Koneru
>            Assignee: LiXin Ge
>            Priority: Major
>             Fix For: 0.2.1
>
>         Attachments: HDDS-265.000.patch, HDDS-265.001.patch, HDDS-265.002.patch
>
>
> "numPendingDeletionBlocks" and "deleteTransactionId" fields are specific to KeyValueContainers.
As such they should be moved to KeyValueContainerData from ContainerData.
> ContainerReport should also be refactored to take in this change. 
> Please refer to [~ljain]'s comment in HDDS-250.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message