hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Templeton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-13746) Still occasional "Should be different group" failure in TestRefreshUserMappings#testGroupMappingRefresh
Date Fri, 10 Aug 2018 21:57:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-13746?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16576903#comment-16576903
] 

Daniel Templeton commented on HDFS-13746:
-----------------------------------------

Thanks for the patch, [~smeng].  Yeah, that test is known flaky.  Here are my comments:

* Why {{Groups.LOG}}?  This output has nothing to do with that class.  I'd just create my
own logger for the test class.  For one of many, many examples, see {{TestImmutableSnapshot}}.
* On your sleep timing, I don't see the need for the initial 1000ms * {{groupRefreshTimeoutSec}}
sleep.  I also don't see that the max number of trials is governed by the {{groupRefreshTimeoutSec}}.
 You'd be better off dropping the first sleep and making the max number of trials be a factor
of {{groupRefreshTimeoutSec}}.
* Logging at WARN level should be for things that are going wrong and can be addressed.  Your
log messages in this patch should be INFO or DEBUG.
* I don't think the log message inside the loop is helpful.  It produces a ton of output that
makes the rest of the logs harder to read.  Really what you're trying to show if how many
trials it took to pass.  So say that instead when it's done, e.g. "Cache timeout took 1250ms
to take effect."
* Why did you need to write {{isSameStrList()}} instead of using {{List.equals()}}?

> Still occasional "Should be different group" failure in TestRefreshUserMappings#testGroupMappingRefresh
> -------------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-13746
>                 URL: https://issues.apache.org/jira/browse/HDFS-13746
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Siyao Meng
>            Assignee: Siyao Meng
>            Priority: Major
>         Attachments: HDFS-13746.001.patch, HDFS-13746.002.patch
>
>
> In https://issues.apache.org/jira/browse/HDFS-13723, increasing the amount of time in
sleep() helps but the problem still appears, which is annoying.
>  
> Solution:
> Use a loop to allow the test case to fail 100(MAX_RETRIES) times before declaring failure.
Wait 50 ms between each retry.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message