hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiaoyu Yao (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HDDS-123) ContainerSet class to manage ContainerMap
Date Mon, 04 Jun 2018 23:02:00 GMT

    [ https://issues.apache.org/jira/browse/HDDS-123?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16500996#comment-16500996
] 

Xiaoyu Yao edited comment on HDDS-123 at 6/4/18 11:01 PM:
----------------------------------------------------------

Thanks [~bharatviswa] for the patch. The v3 patch LGTM, I only have one minor comment

 

ContainerSet.java

{color:#000000}Line 66: should we use {color}{color:#1948a6}containerMap{color}{color:#000000}.putIfAbsent(containerId,container)
and use the returned value to determine whether the container has been inserted or not as
the map entries may change between get() and put()?{color}


was (Author: xyao):
Thanks [~bharatviswa] for the patch. The v3 patch LGTM, I only have one comment:

 

ContainerSet.java

{color:#000000}Line 66: should we use {color}{color:#1948a6}containerMap{color}{color:#000000}.putIfAbsent(containerId,container)
and use the returned value to determine whether the container has been inserted or not as
the map entries may change between get() and put()?{color}

> ContainerSet class to manage ContainerMap 
> ------------------------------------------
>
>                 Key: HDDS-123
>                 URL: https://issues.apache.org/jira/browse/HDDS-123
>             Project: Hadoop Distributed Data Store
>          Issue Type: Sub-task
>            Reporter: Bharat Viswanadham
>            Assignee: Bharat Viswanadham
>            Priority: Major
>             Fix For: 0.2.1
>
>         Attachments: HDDS-123-HDDS-48.00.patch, HDDS-123-HDDS-48.01.patch, HDDS-123-HDDS-48.02.patch,
HDDS-123-HDDS-48.03.patch
>
>
> Create a ContainerSet class, which manages containerMap.
> Previously container map is in ContainerManagerImpl, with refactoring work it should
be moved to ContainerSet. 
> This class should handle add/get/remove container from containerMap.
> And also now it should handle containerReport.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message