hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Íñigo Goiri (JIRA) <j...@apache.org>
Subject [jira] [Commented] (HDFS-13215) RBF: Move Router to its own module
Date Thu, 15 Mar 2018 17:13:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-13215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16400751#comment-16400751
] 

Íñigo Goiri commented on HDFS-13215:
------------------------------------

It looks like Yetus didn't run the unit tests for RBF: [here|https://builds.apache.org/job/PreCommit-HDFS-Build/23499/testReport/].
Not sure what's missing though.

I would call it {{RBFConfigKeys}} instead of {{RbfConfigKeys}} (similar for TestRbfConfigFields).

I would avoid making changes like the ones in FederationMetrics.
We should do a separate JIRA for those.
Can we do a separate JIRA for:
* hadoop-hdfs-project/hadoop-hdfs-rbf/src/main/java/org/apache/hadoop/hdfs/protocolPB/package-info.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/federation/metrics/FederationMetrics.java
* hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/federation/router/Router.java
(javadoc comment)
* hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/federation/router/TestRouterQuota.java
(javadoc comment)

Similarly, we should avoid the space changes in {{DFSConfigKeys}} (towards the end of the
diff).

Thanks for taking this [~ywskycn], this is a lot of work.

> RBF: Move Router to its own module
> ----------------------------------
>
>                 Key: HDFS-13215
>                 URL: https://issues.apache.org/jira/browse/HDFS-13215
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Íñigo Goiri
>            Assignee: Wei Yan
>            Priority: Major
>         Attachments: HDFS-13215.000.patch, HDFS-13215.001.patch, HDFS-13215.002.patch,
HDFS-13215.003.patch, HDFS-13215.004.patch
>
>
> We are splitting the HDFS client code base and potentially Router-based Federation is
also independent enough to be in its own package.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message