hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "BELUGA BEHR (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-13193) Various Improvements for BlockTokenSecretManager.java
Date Mon, 26 Feb 2018 20:46:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-13193?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16377550#comment-16377550
] 

BELUGA BEHR commented on HDFS-13193:
------------------------------------

I will try to do the logging changes next week.  If you would like, we can commit these changes
and I can do it in a new JIRA.  Just let me know

> Various Improvements for BlockTokenSecretManager.java
> -----------------------------------------------------
>
>                 Key: HDFS-13193
>                 URL: https://issues.apache.org/jira/browse/HDFS-13193
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: hdfs
>    Affects Versions: 3.0.0
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Trivial
>         Attachments: HDFS-13193.1.patch
>
>
> Various improvements for class {{org.apache.hadoop.hdfs.security.token.block.BlockTokenSecretManager.java}}
> # Remove superfluous {{toString}} calls
> # Fix some checkstyle warnings
> # Re-implement method with O(N^2) with HashMultiSet - also improves readability
> # Increase code re-use with Apache Commons Library



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message