hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yiqun Lin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-13043) RBF: Expose the state of the Routers in the federation
Date Tue, 30 Jan 2018 08:45:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-13043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16344691#comment-16344691
] 

Yiqun Lin commented on HDFS-13043:
----------------------------------

Hi [~elgoiri], agree on your comments. There seems still some places we need to update:

Please attach the clean patch, there was one redundant file added in patch.

*federationhealth.html*
 line263:. Would you update the name to a more readable name like {{Membership(last update)}}?
 line264:. Would you update the name to a more readable name like {{Mount table(last update)}}?
 line276: This should be simplified as \{lastMountTableUpdate}.

*TestMetricsBase.java*
 line142 and 152: Can you use {{Time.now}} to set the field {{membershipVersion}} or {{mountTableVersion}}
like following?
{code:java}
router1.setStateStoreVersion(StateStoreVersion.newInstance(Time.now() -2000, Time.now() -1000));
{code}
The json string got in test will look more real and accurate.

In addition, can you attach the new screenshot again base on the latest patch?

> RBF: Expose the state of the Routers in the federation
> ------------------------------------------------------
>
>                 Key: HDFS-13043
>                 URL: https://issues.apache.org/jira/browse/HDFS-13043
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>            Reporter: Íñigo Goiri
>            Assignee: Íñigo Goiri
>            Priority: Major
>         Attachments: HDFS-13043.000.patch, HDFS-13043.001.patch, HDFS-13043.002.patch,
HDFS-13043.003.patch, HDFS-13043.004.patch, HDFS-13043.005.patch, router-info.png
>
>
> The Router should expose the state of the other Routers in the federation through a user
UI.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message