hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Douglas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-12681) Make HdfsLocatedFileStatus a subtype of LocatedFileStatus
Date Wed, 22 Nov 2017 17:13:01 GMT

    [ https://issues.apache.org/jira/browse/HDFS-12681?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16262929#comment-16262929
] 

Chris Douglas commented on HDFS-12681:
--------------------------------------

bq. I've been doing some stuff with subclasses of FileStatus recently and it's not great for
subclassing.
Yes, "not great" is a succinct way to put it. I tend to use more profanity.

While a little unusual, the above seemed like the least-convoluted way to support all the
constraints on the design without bleeding changes throughout HDFS. Again, we could extract
an interface from {{FileStatus}}, but the type system wouldn't be verifying anything relevant.

[~stevel@apache.org]/[~bharatviswa]/[~arpiagariu]/[~djp]/[~elgoiri], do you have cycles to
review the patch? This is necessary for HDFS-9806, which we'd like to merge in the next couple
weeks.

> Make HdfsLocatedFileStatus a subtype of LocatedFileStatus
> ---------------------------------------------------------
>
>                 Key: HDFS-12681
>                 URL: https://issues.apache.org/jira/browse/HDFS-12681
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Chris Douglas
>            Assignee: Chris Douglas
>            Priority: Minor
>         Attachments: HDFS-12681.00.patch, HDFS-12681.01.patch, HDFS-12681.02.patch, HDFS-12681.03.patch,
HDFS-12681.04.patch, HDFS-12681.05.patch, HDFS-12681.06.patch, HDFS-12681.07.patch, HDFS-12681.08.patch,
HDFS-12681.09.patch, HDFS-12681.10.patch, HDFS-12681.11.patch, HDFS-12681.12.patch, HDFS-12681.13.patch
>
>
> {{HdfsLocatedFileStatus}} is a subtype of {{HdfsFileStatus}}, but not of {{LocatedFileStatus}}.
Conversion requires copying common fields and shedding unknown data. It would be cleaner and
sufficient for {{HdfsFileStatus}} to extend {{LocatedFileStatus}}.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message