hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Íñigo Goiri (JIRA) <j...@apache.org>
Subject [jira] [Commented] (HDFS-12577) Rename Router tooling
Date Mon, 02 Oct 2017 21:33:01 GMT

    [ https://issues.apache.org/jira/browse/HDFS-12577?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16188880#comment-16188880

Íñigo Goiri commented on HDFS-12577:

For the last few months, we've been getting feedback about the naming issues. I'd like to
use this JIRA to cover these.
I'd like to summarize the different comments:
* [~zhz] and [~shv] were concerned about distinguishing it from regular HDFS federation.
* [~manojg] similarly thought the command line to manage the mount table could get confusing
as it currently used {{hdfs federation}}..
* [~aw] brought up the confusion of having two daemons (in YARN and HDFS) called {{Router}}.

>From this feedback, I propose the following:
* Referring to this effort as "Router-Based Federation" or RBF.
* Create a class called {{HdfsRouter}} to start the Router, so the current main from Router
would move here. The command would still be {{hdfs router}} but it would start {{HdfsRouter}}
and avoid conflicts when calling {{jps}} etc.
* Rename the command I added for HDFS-10467 from {{hdfs federation}} to {{hdfs routeradmin}}.
Alternatively, I could merge both the Router start and the admin into {{hdfs router}} and
call {{HdfsRouter}} and {{RouterAdmin}} internally.


> Rename Router tooling
> ---------------------
>                 Key: HDFS-12577
>                 URL: https://issues.apache.org/jira/browse/HDFS-12577
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: fs
>            Reporter: Íñigo Goiri
>             Fix For: HDFS-10467
> Currently the naming for Router Based Federation has a couple conflicts:
> * Both YARN and HDFS have a Router component which may cause issues for the PID file
and JPS.
> * The tool to manage the mount table is called using {{hdfs federation}}. This may cause
confusion with the regular HDFS federation.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message