hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-12570) [SPS]: Refactor Co-ordinator datanode logic to track the block storage movements
Date Thu, 12 Oct 2017 06:12:02 GMT

    [ https://issues.apache.org/jira/browse/HDFS-12570?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16201504#comment-16201504
] 

Rakesh R commented on HDFS-12570:
---------------------------------

Thanks a lot [~umamaheswararao] for the detailed review comments and suggestions.

Addressed below comments and taken care in the latest patch:

Comment-1) modified the config key name.
Comment-2) Fixed typo.
Comment-3) Since not differentiating NO, FEW, ALL paired I've clubbed these together. In the
new patch, I added {{BlocksMovingAnalysis.Status.NO_BLOCKS_TARGETS_PAIRED}} for much better
readability and logic more clear covering all the corner cases.
Comment-4) Cleaned up the unwanted comment.
Comment-5) Moved the {{blockCount++;}} inside for-loop. Hope this is fine.
Comment-6) Updated BlockStorageMovementCommand class level doc
Comment-7) Updated the doc.


> [SPS]: Refactor Co-ordinator datanode logic to track the block storage movements
> --------------------------------------------------------------------------------
>
>                 Key: HDFS-12570
>                 URL: https://issues.apache.org/jira/browse/HDFS-12570
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>            Reporter: Rakesh R
>            Assignee: Rakesh R
>         Attachments: HDFS-12570-HDFS-10285-00.patch, HDFS-12570-HDFS-10285-01.patch,
HDFS-12570-HDFS-10285-02.patch, HDFS-12570-HDFS-10285-03.patch
>
>
> This task is to refactor the C-DN block storage movements. Basically, the idea is to
move the scheduling and tracking logic to Namenode rather than at the special C-DN. Please
refer the discussion with [~andrew.wang] to understand the [background and the necessity of
refactoring|https://issues.apache.org/jira/browse/HDFS-10285?focusedCommentId=16141060&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16141060].



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message