hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Subru Krishnan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-7550) Minor followon cleanups from HDFS-7543
Date Wed, 11 Oct 2017 23:14:00 GMT

     [ https://issues.apache.org/jira/browse/HDFS-7550?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Subru Krishnan updated HDFS-7550:
    Target Version/s: 3.1.0  (was: 2.9.0)

> Minor followon cleanups from HDFS-7543
> --------------------------------------
>                 Key: HDFS-7550
>                 URL: https://issues.apache.org/jira/browse/HDFS-7550
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>    Affects Versions: 2.7.0
>            Reporter: Charles Lamb
>            Priority: Minor
>         Attachments: HDFS-7550.001.patch
> The commit of HDFS-7543 crossed paths with these comments:
> FSDirMkdirOp.java
> in #mkdirs, you removed the final String srcArg = src. This should be left in. Many IDEs
will whine about making assignments to formal args and that's why it was put in in the first
> FSDirRenameOp.java
> #renameToInt, dstIIP (and resultingStat) could benefit from final's.
> FSDirXAttrOp.java
> I'm not sure why you've moved the call to getINodesInPath4Write and checkXAttrChangeAccess
inside the writeLock.
> FSDirStatAndListing.java
> The javadoc for the @param src needs to be changed to reflect that it's an INodesInPath,
not a String. Nit: it might be better to rename the INodesInPath arg from src to iip.
> #getFileInfo4DotSnapshot is now unused since you in-lined it into #getFileInfo.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message