hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Mackrory (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11096) Support rolling upgrade between 2.x and 3.x
Date Fri, 08 Sep 2017 15:18:02 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11096?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16158780#comment-16158780
] 

Sean Mackrory commented on HDFS-11096:
--------------------------------------

Thanks for the reviews. I was hoping you'd take a look [~aw]! I'll update the patch and address
these comments soon.

I've also been reviewing more recent JACC reports. There are still a few incompatibilities
that technically violate the contract that I mentioned above, like metrics being replace by
metrics2, s3:// disappearing entirely, but neither being labelled as deprecated for all of
2.x, some things that should not have been used publicly (like LOGs) changing data types,
etc.  These are things that from a practical standpoint, have been known about by many for
a long time and no concern has been raised, and there's significant baggage to addressing
them. Does anybody think they warrant further action? I'm inclined to say no...

> Support rolling upgrade between 2.x and 3.x
> -------------------------------------------
>
>                 Key: HDFS-11096
>                 URL: https://issues.apache.org/jira/browse/HDFS-11096
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: rolling upgrades
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Andrew Wang
>            Assignee: Sean Mackrory
>            Priority: Blocker
>         Attachments: HDFS-11096.001.patch, HDFS-11096.002.patch
>
>
> trunk has a minimum software version of 3.0.0-alpha1. This means we can't rolling upgrade
between branch-2 and trunk.
> This is a showstopper for large deployments. Unless there are very compelling reasons
to break compatibility, let's restore the ability to rolling upgrade to 3.x releases.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message