hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Huafeng Wang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-12269) Better to return a Map rather than HashMap in getErasureCodingCodecs
Date Mon, 07 Aug 2017 10:10:00 GMT
Huafeng Wang created HDFS-12269:
-----------------------------------

             Summary: Better to return a Map rather than HashMap in getErasureCodingCodecs
                 Key: HDFS-12269
                 URL: https://issues.apache.org/jira/browse/HDFS-12269
             Project: Hadoop HDFS
          Issue Type: Improvement
          Components: erasure-coding
            Reporter: Huafeng Wang
            Assignee: Huafeng Wang
            Priority: Minor


Currently the getErasureCodingCodecs function defined in ClientProtocal returns a Hashmap:
{code:java}
  HashMap<String, String> getErasureCodingCodecs() throws IOException;
{code}
It's better to return a Map.




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message