hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manoj Govindassamy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-12206) Rename the split EC / replicated block metrics
Date Fri, 28 Jul 2017 16:38:00 GMT

    [ https://issues.apache.org/jira/browse/HDFS-12206?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16105266#comment-16105266

Manoj Govindassamy commented on HDFS-12206:

The reason why I chose "stat" suffix earlier was to differentiate the new separated metrics
from the already existing aggregated metrics and also to avoid overlapping names like "getCorruptReplicaBlocks"
vs "getCorruptReplicatedBlocks". Yes, the changes need to be propagated all the way down like
{{LowRedundancyBlocks}}, other places like {{ECBlockGroupStats}} and looks like it will be
taken care later.

Code refactoring in patch v01 looks good to me, +1. 

> Rename the split EC / replicated block metrics
> ----------------------------------------------
>                 Key: HDFS-12206
>                 URL: https://issues.apache.org/jira/browse/HDFS-12206
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: metrics
>    Affects Versions: 3.0.0-alpha4
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>              Labels: hdfs-ec-3.0-must-do
>         Attachments: HDFS-12206.001.patch
> Going through the split EC/replicated metrics, I think it'd be better to name the replicated-only
metrics with "ReplicatedBlocks" rather than "BlocksStat" for clarity. "Stat" is also not a
very descriptive name, so remove it for the EC blocks as well. Finally, fix some inconsistencies
that were missed earlier.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message