hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yiqun Lin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-12086) Ozone: Add the unit test for KSMMetrics
Date Wed, 05 Jul 2017 03:23:01 GMT

     [ https://issues.apache.org/jira/browse/HDFS-12086?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Yiqun Lin updated HDFS-12086:
-----------------------------
    Attachment: HDFS-12086-HDFS-7240.001.patch

Attach the initial patch. Some notes will help you review:

* New added each request type metrics for volume, bucket and key ops.
* Update the inconsistent metric names.
* Add the new test class for testing all the existing metrics in {{KSMMetrics.java}}

Any comments is welcomed.

> Ozone: Add the unit test for KSMMetrics
> ---------------------------------------
>
>                 Key: HDFS-12086
>                 URL: https://issues.apache.org/jira/browse/HDFS-12086
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: test
>    Affects Versions: HDFS-7240
>            Reporter: Yiqun Lin
>            Assignee: Yiqun Lin
>         Attachments: HDFS-12086-HDFS-7240.001.patch
>
>
> Currently the unit test for KSMMetrics is missing. And some metrics name is inconsistent
with that in documentation:
> * numVolumeModifies should be numVolumeUpdates
> * numBucketModifies should be numBucketUpdates



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message