hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-10999) Introduce separate stats for Replicated and Erasure Coded Blocks apart from the current Aggregated stats
Date Wed, 07 Jun 2017 02:00:23 GMT

    [ https://issues.apache.org/jira/browse/HDFS-10999?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16040006#comment-16040006

Andrew Wang commented on HDFS-10999:

Thanks for the rev Manoj, great work synthesizing the review comments. We're close, just some
touch-up issues now:

* Regarding "CorruptReplicaOne" and similar, the full name is "corrupt replication factor
one". Abbreviating it as "CorruptReplicaOne" is a bit ambiguous since "replica" has its own
meaning. I'd prefer we name all these as "CorruptReplOne" or "CorruptReplicationOne" instead.
* BlocksStats#toString and ECBlockGroupsStats, optional, but should the names be expanded
to match the field names? In terms of code formatting, it'd also be clearer if the key and
value were on the same line.
* Need javadoc on methods in ECBlockGroupsStatsMBean and ReplicatedBlocksStatsMBean. Javadoc
on aggregate methods in FSNamesystemMBean should make it clear that they are aggregates too.

Looks like some of my testing comments from last time were not addressed. Do you prefer to
handle this in a follow-on JIRA? If so, appreciate if you could file that and link it here.
Still a bit concerned about the TODO in TestNameNodeMetrics.

> Introduce separate stats for Replicated and Erasure Coded Blocks apart from the current
Aggregated stats
> --------------------------------------------------------------------------------------------------------
>                 Key: HDFS-10999
>                 URL: https://issues.apache.org/jira/browse/HDFS-10999
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Wei-Chiu Chuang
>            Assignee: Manoj Govindassamy
>              Labels: hdfs-ec-3.0-nice-to-have, supportability
>         Attachments: HDFS-10999.01.patch, HDFS-10999.02.patch, HDFS-10999.03.patch
> Per HDFS-9857, it seems in the Hadoop 3 world, people prefer the more generic term "low
redundancy" to the old-fashioned "under replicated". But this term is still being used in
messages in several places, such as web ui, dfsadmin and fsck. We should probably change them
to avoid confusion.
> File this jira to discuss it.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message