hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rakesh R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11541) Call RawErasureEncoder and RawErasureDecoder release() methods
Date Mon, 27 Mar 2017 10:15:41 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11541?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15943003#comment-15943003

Rakesh R commented on HDFS-11541:

Thanks [~Sammi] for the patch. {{getDecoder()}} is used by both StripedBlockChecksumReconstructor
and StripedBlockReconstructor classes. How about adding a new method like below and call the
same in both the above impl classes.
  void cleanup(){

> Call RawErasureEncoder and RawErasureDecoder release() methods
> --------------------------------------------------------------
>                 Key: HDFS-11541
>                 URL: https://issues.apache.org/jira/browse/HDFS-11541
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha2
>            Reporter: László Bence Nagy
>            Assignee: SammiChen
>              Labels: hdfs-ec-3.0-nice-to-have
>         Attachments: HDFS-11541-01.patch, HDFS-11541-02.patch
> The *RawErasureEncoder* and *RawErasureDecoder* classes have _release()_ methods which
are not called from the source code. These methods should be called when an encoding or decoding
operation is finished so that the dynamically allocated resources can be freed. Underlying
native plugins can also rely on these functions to release their resources.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message