hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Lowe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-11498) Make RestCsrfPreventionHandler and WebHdfsHandler compatible with Netty 4.0
Date Mon, 06 Mar 2017 15:15:33 GMT

     [ https://issues.apache.org/jira/browse/HDFS-11498?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jason Lowe updated HDFS-11498:
------------------------------
    Attachment: HDFS-11498.001.patch

+1, branch-2 patch looks good to me.  The javac warning is unrelated as are the unit tests,
and the tests pass on branch-2 for me with the patch applied.

I believe the simplest path forward is to commit this patch to trunk, branch-2, branch-2.8
and branch-2.8.0 then update HADOOP-13866 accordingly.  We do not want to ship a 4.x beta
even on trunk.

Uploading essentially the same patch (except for line number offsets) for trunk, and I'll
commit this pending that Jenkins run.  

> Make RestCsrfPreventionHandler and WebHdfsHandler compatible with Netty 4.0
> ---------------------------------------------------------------------------
>
>                 Key: HDFS-11498
>                 URL: https://issues.apache.org/jira/browse/HDFS-11498
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.8.0
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>         Attachments: HDFS-11498.001.patch, HDFS-11498.branch-2.001.patch
>
>
> Per discussion in HADOOP-13866, it looks like we can change 2.8.0 back to exposing Netty
4.0, but still be ABI compatible with Netty 4.1 for users like HBase that want to swap out
the version.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message