hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11465) Rename BlockType#CONTIGUOUS to BlockType#REPLICATED
Date Wed, 15 Mar 2017 23:40:41 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11465?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15927194#comment-15927194

Andrew Wang commented on HDFS-11465:

Hi [~yuanbo], thanks for picking this up. Upon further thought, I don't think we should bother
with this rename. Right now, the javadoc and usages equate striped/EC and contiguous/replicated.
I think untangling this will be a major challenge for when we implement contiguous EC, so
we can leave this for then. At the least, BlockType correctly contrasts striped with contiguous,
which are on the same axis.

> Rename BlockType#CONTIGUOUS to BlockType#REPLICATED
> ---------------------------------------------------
>                 Key: HDFS-11465
>                 URL: https://issues.apache.org/jira/browse/HDFS-11465
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Andrew Wang
>            Assignee: Yuanbo Liu
>         Attachments: HDFS-11465.001.patch
> HDFS-10759 introduced the a BlockType enum to INodeFile, with possible values CONTIGUOUS
> Since HDFS-8030 wants to implement "contiguous EC", CONTIGUOUS isn't an appropriate name.
I propose we rename CONTIGUOUS to REPLICATED for clarity.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message