hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11465) Rename BlockType#CONTIGUOUS to BlockType#REPLICATED
Date Mon, 27 Feb 2017 23:25:46 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11465?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15886753#comment-15886753
] 

Andrew Wang commented on HDFS-11465:
------------------------------------

Linking some JIRAs, we discussed this a bit on HDFS-11382 as well.

> Rename BlockType#CONTIGUOUS to BlockType#REPLICATED
> ---------------------------------------------------
>
>                 Key: HDFS-11465
>                 URL: https://issues.apache.org/jira/browse/HDFS-11465
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Andrew Wang
>
> HDFS-10759 introduced the a BlockType enum to INodeFile, with possible values CONTIGUOUS
or STRIPED.
> Since HDFS-8030 wants to implement "contiguous EC", CONTIGUOUS isn't an appropriate name.
I propose we rename CONTIGUOUS to REPLICATED for clarity.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message