hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-11427) Rename "rs-default" to "rs"
Date Fri, 24 Feb 2017 19:00:45 GMT

     [ https://issues.apache.org/jira/browse/HDFS-11427?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Andrew Wang updated HDFS-11427:
       Resolution: Fixed
    Fix Version/s: 3.0.0-alpha3
     Release Note: The "rs-default" codec has been renamed to simply "rs" for simplicity.
Previous configuration keys like "io.erasurecode.codec.rs-default" have also been renamed
to match.
           Status: Resolved  (was: Patch Available)

Thanks for the review Wei-chiu! Committed to trunk.

> Rename "rs-default" to "rs"
> ---------------------------
>                 Key: HDFS-11427
>                 URL: https://issues.apache.org/jira/browse/HDFS-11427
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>              Labels: hdfs-ec-3.0-must-do
>             Fix For: 3.0.0-alpha3
>         Attachments: HDFS-11427.001.patch, HDFS-11427.002.patch
> I think it's confusing (and verbose) that our RS code is named "rs-default" instead of
just "rs", partially because we also have the idea of setting a default implementation for
each codec. Let's rename it for simplicity.
> This is an incompatible change since it affects some configuration keys.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message