hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11427) Rename "rs-legacy" to "rs"
Date Sat, 18 Feb 2017 20:11:44 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15873320#comment-15873320

Allen Wittenauer commented on HDFS-11427:

History has shown that naming anything with "default" is extremely problematic when the default
needs to change. :(

> Rename "rs-legacy" to "rs"
> --------------------------
>                 Key: HDFS-11427
>                 URL: https://issues.apache.org/jira/browse/HDFS-11427
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>              Labels: hdfs-ec-3.0-must-do
>         Attachments: HDFS-11427.001.patch
> I think it's confusing (and verbose) that our RS code is named "rs-default" instead of
just "rs", partially because we also have the idea of setting a default implementation for
each codec. Let's rename it for simplicity.
> This is an incompatible change since it affects some configuration keys.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message