hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11405) Rename "erasurecode" CLI subcommand to "ec"
Date Wed, 22 Feb 2017 00:38:44 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11405?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15877103#comment-15877103
] 

Hudson commented on HDFS-11405:
-------------------------------

SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11284 (See [https://builds.apache.org/job/Hadoop-trunk-Commit/11284/])
HDFS-11405. Rename "erasurecode" CLI subcommand to "ec". Contributed by (wang: rev fc9ad3ce3aa7d28974b0ac3b554089507c124783)
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HDFSCommands.md
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/bin/hdfs
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/test/resources/testErasureCodingConf.xml
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HDFSErasureCoding.md
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/erasurecode/ECCli.java


> Rename "erasurecode" CLI subcommand to "ec"
> -------------------------------------------
>
>                 Key: HDFS-11405
>                 URL: https://issues.apache.org/jira/browse/HDFS-11405
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Andrew Wang
>            Assignee: Manoj Govindassamy
>            Priority: Blocker
>             Fix For: 3.0.0-alpha3
>
>         Attachments: HDFS-11405.01.patch
>
>
> Right now the erasure coding CLI subcommand is "erasurecode". I think it'd be nice to
shorten this to just "ec".
> We've shortened things like "memory caching" to "cache" or "at rest encryption" to "crypto"
for ease of use, this is in the same style.
> This would also require doc updates.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message