hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-11405) Rename "erasurecode" CLI subcommand to "ec"
Date Tue, 21 Feb 2017 21:56:44 GMT

     [ https://issues.apache.org/jira/browse/HDFS-11405?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Andrew Wang updated HDFS-11405:
       Resolution: Fixed
    Fix Version/s: 3.0.0-alpha3
     Release Note: The "hdfs erasurecode" CLI command has been renamed to "hdfs ec" for ease-of-use.
           Status: Resolved  (was: Patch Available)

Thanks Manoj for the patch and Wei-Chiu for reviewing! I've committed this to trunk.

> Rename "erasurecode" CLI subcommand to "ec"
> -------------------------------------------
>                 Key: HDFS-11405
>                 URL: https://issues.apache.org/jira/browse/HDFS-11405
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Andrew Wang
>            Assignee: Manoj Govindassamy
>            Priority: Blocker
>             Fix For: 3.0.0-alpha3
>         Attachments: HDFS-11405.01.patch
> Right now the erasure coding CLI subcommand is "erasurecode". I think it'd be nice to
shorten this to just "ec".
> We've shortened things like "memory caching" to "cache" or "at rest encryption" to "crypto"
for ease of use, this is in the same style.
> This would also require doc updates.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org

View raw message