hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-11273) Move TransferFsImage#doGetUrl function to a Util class
Date Tue, 10 Jan 2017 02:56:59 GMT

    [ https://issues.apache.org/jira/browse/HDFS-11273?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15813659#comment-15813659
] 

Hudson commented on HDFS-11273:
-------------------------------

SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11095 (See [https://builds.apache.org/job/Hadoop-trunk-Commit/11095/])
HDFS-11273. Move TransferFsImage#doGetUrl function to a Util class. (jing9: rev 7ec609b28989303fe0cc36812f225028b0251b32)
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NameNodeRpcServer.java
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/Util.java
* (add) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/HttpPutFailedException.java
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/EditLogFileInputStream.java
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/ImageServlet.java
* (edit) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/TransferFsImage.java
* (add) hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/common/HttpGetFailedException.java


> Move TransferFsImage#doGetUrl function to a Util class
> ------------------------------------------------------
>
>                 Key: HDFS-11273
>                 URL: https://issues.apache.org/jira/browse/HDFS-11273
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Hanisha Koneru
>            Assignee: Hanisha Koneru
>             Fix For: 3.0.0-alpha2
>
>         Attachments: HDFS-11273.000.patch, HDFS-11273.001.patch, HDFS-11273.002.patch,
HDFS-11273.003.patch, HDFS-11273.004.patch
>
>
> TransferFsImage#doGetUrl downloads files from the specified url and stores them in the
specified storage location. HDFS-4025 plans to synchronize the log segments in JournalNodes.
If a log segment is missing from a JN, the JN downloads it from another JN which has the required
log segment. We need TransferFsImage#doGetUrl and TransferFsImage#receiveFile to accomplish
this. 
> So we propose to move the said functions to a Utility class so as to be able to use it
for JournalNode syncing as well, without duplication of code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message