hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hanisha Koneru (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-11273) Move TransferFsImage#doGetUrl function to a Util class
Date Wed, 04 Jan 2017 23:39:58 GMT

     [ https://issues.apache.org/jira/browse/HDFS-11273?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hanisha Koneru updated HDFS-11273:
----------------------------------
    Attachment: HDFS-11273.002.patch

Thank you [~jingzhao]. I have uploaded patch v02 with the new changes.

> Move TransferFsImage#doGetUrl function to a Util class
> ------------------------------------------------------
>
>                 Key: HDFS-11273
>                 URL: https://issues.apache.org/jira/browse/HDFS-11273
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Hanisha Koneru
>            Assignee: Hanisha Koneru
>         Attachments: HDFS-11273.000.patch, HDFS-11273.001.patch, HDFS-11273.002.patch
>
>
> TransferFsImage#doGetUrl downloads files from the specified url and stores them in the
specified storage location. HDFS-4025 plans to synchronize the log segments in JournalNodes.
If a log segment is missing from a JN, the JN downloads it from another JN which has the required
log segment. We need TransferFsImage#doGetUrl and TransferFsImage#receiveFile to accomplish
this. 
> So we propose to move the said functions to a Utility class so as to be able to use it
for JournalNode syncing as well, without duplication of code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org


Mime
View raw message